Index | Support Requests & Bugs | Timer Sync Log File



Timer Sync Log File


Hi,


Is there a way of turning off the verbose logging for the timer sync application?  I have a lean SSD startup drive and I'm finding that the logs created in my Users\UserName\AppData\Roaming\invoiceSync folder are getting really large!

Cheers,

David.



5:05 AM 3/24/2011 (6 years ago)
David


David, download & install the latest version (2.0.0.23), open the Settings and then the Logging tab. Select "No logging". Restart timeSync. Hope this will stop the logging.



10:32 AM 3/24/2011 (6 years ago)


Hi Goran,

Thanks - that seems to have done the trick!

Cheers,

David.



11:18 AM 3/28/2011 (6 years ago)
David


Hi Goran,


I am having a similar issue with the software performing lots and lots of read/writes to the log file (and affecting the overall computer performance.) I'd like to try this new version where I can disable login, but can't find it on the website. The latest version is the .20 that I have installed... which does not have the LOG tab.


Let me know... I'd love to see if this resolves the problem in which case, I am ready to purchase.


Eric.



3:26 AM 4/7/2011 (6 years ago)
Eric


Hi Goran,


I downloaded anyhow, and noticed I now have .23... the web page is just mis-labeled but the right version does come down.

I've disabled local logging, but I still see a real constant WRITE to \AppData\Roaming\InvoiceSync\Localstore.FDB.

I'm not running any times, just looking at a stopped timer.

Why is there such constant WRITE activity to this file? Over time, it really degrades the performance of my workstation. Note, timerSync.exe is either 1 or 2 on the Resource Monitor on Disk Activity over time. It seems high for a small utility that's not actually doing anything and it way outranks other software on my machine that I am using constantly.

FYI, I am also running on an SSD for my system drive.

I really love the timers and any information on how to resolve this would be much appreciated.

Eric



3:37 AM 4/7/2011 (6 years ago)
Eric


Eric, firstly thank you for your order!

About the WRITE activity you describe, normally I would say it is from the auto-save feature, but this should not take place if the timers are not running. Anyway, you can disable the auto-save by unchecking the "Auto-save locally" option in the Settings window (at the bottom-right position). 

Let me know if this stops the write. 



5:25 AM 4/7/2011 (6 years ago)


I see now this what you said, the constant WRITE in the resource monitor. I switched the option for auto-save, but this still continues and I am not writting anything to there. This file is a FireBird  database where I store some settings (account settings and local data when switfcing to offline mode). It looks like this activity is from the internal database threads and I don't see a way of stopping them. I use the embedded FireBird server version, so it is in the same process as timerSync.exe.

I am not sure what to do here to stop this activity, but certainly I'll start looking for alternatives to FireBird.



6:19 AM 4/7/2011 (6 years ago)


Yes, I noticed the same behavior where the writes continue even after killing the Auto-Save. Interesting about FireBird. I was not aware of it... seems interesting, but yes, this constant write is very odd. I'll test some more to see at what time it starts to degrade performance. It seems it's only after 12 hours or more that it slows my workstation down (overnight). I noticed it because I have a very high performance setup and over the last few weeks, it seemed like I needed to reboot daily. I observed CPU was low (I have a quad core duo) and memory was way low... so then I started looking for Disk Writes and that's where I found it. timerSync had a very large Total in disk writes. Stopping it brought some performance back. Now, I've restarted and have been running timerSync for about 1-2 hours. Performance seems ok and the timerSync number is low at 98k bytes per second - but remaining constant. (It was much higher, though I did not note the previous number.) 

Anyhow, I'm going to leave it running - no timers or anything else - overnight (I am ending my day) and then I'll check again to see tomorrow if the bytes/sec has changed. I'll report back what I find.

Thanks for your prompt response!!

Eric.



6:26 AM 4/7/2011 (6 years ago)
Eric


Thank you, Eric!



6:32 AM 4/7/2011 (6 years ago)


Yes, I noticed the same behavior where the writes continue even after killing the Auto-Save. Interesting about FireBird. I was not aware of it... seems interesting, but yes, this constant write is very odd. I'll test some more to see at what time it starts to degrade performance. It seems it's only after 12 hours or more that it slows my workstation down (overnight). I noticed it because I have a very high performance setup and over the last few weeks, it seemed like I needed to reboot daily. I observed CPU was low (I have a quad core duo) and memory was way low... so then I started looking for Disk Writes and that's where I found it. timerSync had a very large Total in disk writes. Stopping it brought some performance back. Now, I've restarted and have been running timerSync for about 1-2 hours. Performance seems ok and the timerSync number is low at 98k bytes per second - but remaining constant. (It was much higher, though I did not note the previous number.) 

Anyhow, I'm going to leave it running - no timers or anything else - overnight (I am ending my day) and then I'll check again to see tomorrow if the bytes/sec has changed. I'll report back what I find.

Thanks for your prompt response!!

Eric.



6:33 AM 4/7/2011 (6 years ago)
Eric


Great program, use it every day but seeing 12 writes per second to

\AppData\Roaming\InvoiceSync\Localstore.FDB.

Since I'm using an SSD, figured I'd move the folder to a ramdisk.  Any other options or solutions are welcomed.



10:35 PM 10/28/2014 (3 years ago)
jonincanada


Try turning off the 'Auto-save locally' option in the Settings.



6:43 AM 10/29/2014 (3 years ago)




Email* (private)

Display Name*

Web site (public)